首页 > 炒股技巧

通达信黑马888主图指标公式

admin 炒股技巧 2019-06-29 20:21:20
后台-系统设置-扩展变量-手机广告位-内容正文底部
顶底开关:=1;

点位差:=1;

指定点:=10;

笔:=0;

M1:=0;

M2:=0;

M3:=0;

M4:=0;

DRAWGBK(O>0,RGB(33,47,58),RGB(0,0,0),0,'02',0);

{标缺口}

LL:=REF(L,1);HH:=REF(H,1);上跳:=L>HH;下跳:=H<LL;

STICKLINE(L>REF(H,1),L,REF(H,1),3.1,-1),COLORRED;

STICKLINE(REF(L,1)>H,REF(L,1),H,3.1,-1),COLORGREEN;

{灰色}

STICKLINE(O>=C,H,L,0,0),COLOR909090;

STICKLINE(O>=C,C,O,3.1,0),COLOR606060;

STICKLINE(O>=C,C,O,2.1,0),COLOR707070;

STICKLINE(O>=C,C,O,1.2,0),COLOR808080;

STICKLINE(O>=C,C,O,0.2,0),COLOR909090;

STICKLINE(O<=C,H,L,0,0),COLOR666B6F;

STICKLINE(C>O,C,O,3.1,1),COLOR666B6F;

V2V:=V/REF(V,1)>=1.9 AND C>REF(C,1);

{金黄色}

STICKLINE(V2V,H,L,0,0),COLORYELLOW;

STICKLINE(V2V,O,C,3.1,0),COLOR0033FF;

STICKLINE(V2V,O,C,2.1,0),COLOR0077FF;

STICKLINE(V2V,O,C,1.1,0),COLOR00BBFF;

STICKLINE(V2V,O,C,0.1,0),COLOR00FFFF;

{涨停粉}

ZT:=C/REF(C,1)>1.097;

ZT数:COUNT(ZT,BARSSINCE(ZT)),NODRAW;

{涨停红色}

ZDF:=(C-REF(C,1))/REF(C,1)*100;

STICKLINE(ZDF>9.5,C,O,3.1,0),COLOR0000CC;

STICKLINE(ZDF>9.5,C,O,2.1,0),COLOR0000DD;

STICKLINE(ZDF>9.5,C,O,1.2,0),COLOR0000EE;

STICKLINE(ZDF>9.5,C,O,0.2,0),COLOR0000FF;

STICKLINE(ZDF>9.5,H,L,0,0),COLOR0000FF;

{跌停绿色}

STICKLINE(ZDF<-9.9,O,C,3.1,0),COLOR66CC66;

STICKLINE(ZDF<-9.9,O,C,2.1,0),COLOR77DD77;

STICKLINE(ZDF<-9.9,O,C,1.2,0),COLOR88EE88;

STICKLINE(ZDF<-9.9,O,C,0.2,0),COLOR99FF99;

STICKLINE(ZDF<-9.5,H,L,0,0),COLOR99FF99;

均价:=AMO/VOL/100;

假阴真阳:=C<O AND C>=REF(MIN(C,O),1) AND 均价>REF(均价,1);

{蓝}

DT:=假阴真阳;

STICKLINE(DT,H,L,0,0),COLORFFAA00;

STICKLINE(DT,O,C,3,0),COLORFF3300;

STICKLINE(DT,O,C,2,0),COLORFF7700;

STICKLINE(DT,O,C,1,0),COLORFFAA00;

STICKLINE(DT,O,C,0.1,0),COLORFFFF00;

YX:=REF(O,BARSLAST(假阴真阳));

假阴实顶:YX,COLORFF7700,NODRAW;

STICKLINE(V,YX,YX,1,0),COLORFF7700;

L0:=点位差/100;

前极点精准线:IF(顶底开关=0,CONST(REF(L,指定点)),CONST(REF(H,指定点))),COLOR178448;

DRAWICON(ABS(L-前极点精准线)<=L0,前极点精准线*0.99,38);

DRAWICON(ABS(H-前极点精准线)<=L0,前极点精准线*1.01,39);

{H极点精准线:CONST(REF(H,指定点)),COLOR7777FF;

DRAWICON(ABS(H极点精准线-H)<=L0,H极点精准线*1.01,35);

DRAWICON(ABS(H极点精准线-L)<=L0,H极点精准线*0.99,34);}

{极点精准线:CONST(L),COLOR0077FF;

DRAWICON(ABS(L-极点精准线)<=L0,极点精准线*0.99,1);

DRAWICON(ABS(H-极点精准线)<=L0,极点精准线*1.01,2);

同向极点精准数:COUNT(ABS(L-极点精准线)<=L0,60)-1,COLOR0077FF,NODRAW;

异向极点精准数:COUNT(ABS(H-极点精准线)<=L0,60),COLOR0077FF,NODRAW;

XG:=同向极点精准数>0 AND 异向极点精准数>0;}

DIFF:=10*(EMA(CLOSE,12)-EMA(CLOSE,26));

DEA:=EMA(DIFF,9);

MACD:=2*(DIFF-DEA);

量缩价涨:=C<REF(O,1) AND V<REF(V,1) AND MACD>REF(MACD,1) AND C>REF(C,1) AND REF(C<O,1) AND C>O;

阴KDAY:=BARSLAST(量缩价涨)+1;

STICKLINE(V,REF(O,阴KDAY),REF(O,阴KDAY),3.5,0),COLORMAGENTA;

DRAWICON(CROSS(C,REF(O,阴KDAY)),L,1);

DRAWTEXT_FIX(ISLASTBAR,0.55,0.01,0,CODE),COLORYELLOW;

DRAWTEXT_FIX(ISLASTBAR,0.55,0.05,0,STKNAME)COLORYELLOW;

DRAWTEXT_FIX(ISLASTBAR,0.6,0.05,0,HYBLOCK),COLORCYAN;

DRAWTEXT_FIX(ISLASTBAR,0.6,0,0,DYBLOCK),COLORCYAN;

DRAWTEXT_FIX(ISLASTBAR,0.55,0.85,0,GNBLOCK),COLORMAGENTA;

DRAWTEXT_FIX(ISLASTBAR,0.55,0.90,0,FGBLOCK),COLORMAGENTA;

DRAWTEXT_FIX(ISLASTBAR,0.55,0.95,0,ZSBLOCK);

金叉:=CROSS(EMA(C,1),EMA(C,3));

XXBB:= EMA((CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*4,5)*100;

抄牛底:=REF(XXBB,1)<50 AND XXBB-REF(XXBB,1)>25;

蓝宝石:=抄牛底 AND 金叉;

追拉升:=REF(XXBB,1)>50 AND XXBB-REF(XXBB,1)>40;

{机构增仓}

JA1:=(VOL/C)/2;

A2:=SUM(IF(JA1>100 AND CLOSE>REF(CLOSE,1),JA1,0),0);

A3:=SUM(IF(JA1>100 AND CLOSE<REF(CLOSE,1),JA1,0),0);

A4:=SUM(IF(JA1<100 AND CLOSE>REF(CLOSE,1),JA1,0),0);

A5:=SUM(IF(JA1<100 AND CLOSE<REF(CLOSE,1),JA1,0),0);

A6:=A2+A3+A4+A5;

机买:=(A2/A6)*100;

机卖:=(A3/A6)*100;

主力差:=机买-机卖;

机构加仓:=(主力差>=REF(主力差,1)+1.5)*50 AND 机买>机卖;

机构抄底:=金叉 AND 机构加仓;

DRAWTEXT (机构抄底,L*0.97,'↖机构入驻'),COLORCYAN;

机构追买:=机构加仓 AND 追拉升;

DRAWTEXT (机构追买,L*0.99,'↖机构吃单'),COLORFF00FF;

{均线粘合}

JDIF:=EMA(CLOSE,12)-EMA(CLOSE,26);

JDEA:=EMA(JDIF,9);

JMACD:=(JDIF-JDEA)*2;

JBOLL:=MA(CLOSE,20);

JUPPER:=JBOLL+2*STD(CLOSE,20);

JLOWER:=JBOLL-2*STD(CLOSE,20);

JK1:=CLOSE>OPEN ;

JK2:=VOL>=2*REF(VOL,1);

JK3:=CROSS(JDIF,JDEA) AND JDIF<=0 ;

JK4:=CROSS(CLOSE,JBOLL);

均线粘合:=JK1 AND JK2 AND JK3 AND JK4 ;

机构拉升:=机构加仓 AND 均线粘合;

DRAWTEXT (机构拉升,L*0.97,'↖机构拉升'),COLORFF00FF;

HZ:=EMA(CLOSE,13);

短波:=EMA(HZ,1);

HZ2:=EMA(HZ,8);

拉升一号:=CROSS(短波,HZ2);

DRAWTEXT (拉升一号,L*0.97,'↖黑马拉升'),COLORFF00FF;

{洗盘杀入}

N:=13;

T1W:=CONST(LLVBARS(LOW,N));

T1HIGH:=CONST(REF(HIGH,T1W));

CC:=CONST(CURRBARSCOUNT);

T2:=CONST(BARSLAST((CURRBARSCOUNT >(CC+T1W)) AND (HIGH>T1HIGH)));

T2HIGH:=CONST(REF(HIGH,T2));

T3:=CONST(BARSLAST((CURRBARSCOUNT >(CC+T2)) AND (HIGH>T2HIGH)));

T3HIGH:=CONST(REF(HIGH,T3));

洗盘杀入线:DRAWLINE(CURRBARSCOUNT=T3+1, T3HIGH, ISLASTBAR, T3HIGH, 1),LINETHICK2 COLORWHITE;

DRAWTEXT(ISLASTBAR, T3HIGH, ' 洗盘杀入线')LINETHICK1,COLORWHITE;

{DRAWNUMBER(ISLASTBAR,HHV(C,5)*0.95-0.01,HHV(C,5)*0.95);}{显示数字}

止损点:=(ISLASTBAR,HHV(C,5)*0.95-0.01,HHV(C,5)*0.95);

DRAWTEXT(ISLASTBAR ,止损点,'牛熊线');

止损价:STICKLINE(ISLASTBAR,HHV(C,5)*0.95,HHV(C,5)*0.95,20,2)LINETHICK1;

总股本:=STRCAT(STRCAT('总股本: ',CON2STR(TOTALCAPITAL/1000000,2)),'亿');

流通盘:=STRCAT(STRCAT(' 流通盘: ',CON2STR(CAPITAL/1000000,2)),'亿');

全流通:=STRCAT(' 全流通: ',CON2STR((CAPITAL/1000000)/(TOTALCAPITAL/1000000),2));

市值:=STRCAT(STRCAT(' 流通市值: ',CON2STR((CAPITAL/1000000)*C,2)),'亿');

上市日期:=STRCAT(' 上市日期: ',CON2STR(FINANCE(42),0));

股本市值:=STRCAT('股本市值: ',STRCAT(STRCAT(STRCAT(STRCAT(总股本,流通盘),全流通),市值),上市日期));

市盈率:=STRCAT('市盈率: ',CON2STR(C/FINANCE(33),2));

市销率:=STRCAT(' 市销率: ',CON2STR(C/(FINANCE(20)/FINANCE(1)),2));

市净率:=STRCAT(' 市净率: ',CON2STR(C/FINANCE(34),2));

净资收益率:=STRCAT(' 净资收益率: ',CON2STR(FINANCE(33)/FINANCE(34)*100,2));

毛利率:=STRCAT(' 毛利率: ',CON2STR((FINANCE(20)-FINANCE(21))/FINANCE(20)*100,2));

净利润率:=STRCAT(' 净利润率 ',CON2STR(FINANCE(30)/FINANCE(20)*100,2));

主营利润率:=STRCAT(' 主营利润率 ',CON2STR(FINANCE(23)/FINANCE(20)*100,2));

当前业绩:=STRCAT('当前业绩: ',STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(市盈率,市销率),市净率),净资收益率),毛利率),净利润率),主营利润率));

X1:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;

X2:=(FINANCE(31)+FINANCE(17))/FINANCE(10)*1.4;{盈余公积用资本公积金代替};

X3:=FINANCE(23)/FINANCE(10)*3.3;

X4:=FINANCE(19)/FINANCE(15)*0.6;{缺长期负债或负债总额}

X5:=FINANCE(20)/FINANCE(15)*0.999;

Z值:=X1+X2+X3+X4+X5;

预警:=IF(Z值<1.2,'重警',IF(Z值>=1.2 AND Z值<2.6,'轻警','无警'));

财务预警:=STRCAT('财务预警: ',STRCAT(预警,STRCAT('-Z值: ',CON2STR(Z值,3))));

优质资产率:=STRCAT(' 优质资产率: ',CON2STR((FINANCE(19)-FINANCE(22)-FINANCE(27))/FINANCE(19),2));{理论上越大越好但不同行业有不同标准};

现金负债比:=STRCAT(' 现金负债比: ',CON2STR(FINANCE(25)/FINANCE(15),3));{缺长期负债或负债总额,理论上越大越好但不同行业有不同标准};

财务系数:=STRCAT('风险系数: ',STRCAT(STRCAT(财务预警,优质资产率),现金负债比));

DRAWTEXT_FIX(ISLASTBAR,0.005,0.01,0,财务系数),COLOR888888;

DRAWTEXT_FIX(ISLASTBAR,0.005,0.06,0,当前业绩),COLOR888888;

DRAWTEXT_FIX(ISLASTBAR,0.005,0.115,0,股本市值),COLOR888888;

STICKLINE(CURRBARSCOUNT<=200 AND C/REF(C,1)>=1.095 ,(L+H)/2,(L+H)/2,2,0),COLORMAGENTA;

X_1:=STRCAT(HYBLOCK,1);

X_2:=STRCAT(X_1,DYBLOCK);

X_3:=STRCAT(X_2,1);

DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(X_3,GNBLOCK)),COLORRED;

NOTEXTMA1:MA(CLOSE,M1),COLORWHITE;

NOTEXTMA2:MA(CLOSE,M2),COLORMAGENTA;

NOTEXTMA3:MA(CLOSE,M3),COLORCYAN;

NOTEXTMA4:MA(CLOSE,M4),COLORGREEN;

X_4:=REF(CLOSE,1);

X_5:=REF(HIGH,8)=HHV(HIGH,2*8+1);

X_6:=REF(LOW,8)=LLV(LOW,2*8+1);

X_7:=BACKSET(X_5,8+1);

X_8:=BACKSET(X_6,8+1);

X_9:=FILTER(X_7,8) AND HIGH=HHV(HIGH,8+1);

X_10:=FILTER(X_8,8) AND LOW=LLV(LOW,8+1);

X_11:=BARSLAST(X_9);

X_12:=BARSLAST(X_10);

X_13:=IF(X_9,CURRBARSCOUNT,0);

X_14:=IF(X_10,CURRBARSCOUNT,0);

X_15:=IF(X_11,REF(X_13,X_11),X_13);

X_16:=IF(X_12,REF(X_14,X_12),X_14);

X_17:=CONST(X_15);

X_18:=CONST(X_16);

X_19:=CONST(REF(HIGH,X_17-1));

X_20:=CONST(REF(LOW,X_18-1));

X_21:=REF(X_15,X_11+1);

X_22:=REF(X_16,X_12+1);

X_23:=CONST(X_21);

X_24:=CONST(X_22);

X_25:=CONST(REF(HIGH,X_21-1));

X_26:=CONST(REF(LOW,X_22-1));

X_27:=BACKSET(ISLASTBAR,X_17);

X_28:=BACKSET(ISLASTBAR,X_18);

X_29:=BACKSET(ISLASTBAR,X_21);

X_30:=BACKSET(ISLASTBAR,X_22);

X_31:=INTPART(3*8/5);

X_32:=REF(HIGH,X_31)=HHV(HIGH,2*X_31+1);

X_33:=BACKSET(X_32,X_31+1);

X_34:=FILTER(X_33,X_31) AND HIGH=HHV(HIGH,X_31+1);

X_35:=BARSLAST(X_34);

X_36:=IF(X_34,CURRBARSCOUNT,0);

X_37:=IF(X_35,REF(X_36,X_35),X_36);

X_38:=CONST(X_37);

X_39:=REF(X_37,X_35+1);

X_40:=CONST(X_39);

X_41:=REF(LOW,X_31)=LLV(LOW,2*X_31+1);

X_42:=BACKSET(X_41,X_31+1);

X_43:=FILTER(X_42,X_31) AND LOW=LLV(LOW,X_31+1);

X_44:=BARSLAST(X_43);

X_45:=IF(X_43,CURRBARSCOUNT,0);

X_46:=IF(X_44,REF(X_45,X_44),X_45);

X_47:=CONST(X_46);

X_48:=REF(X_46,X_44+1);

X_49:=CONST(X_48);

X_50:=REF(HIGH,5)=HHV(HIGH,2*5+1);

X_51:=FILTER(X_50,5);

X_52:=BACKSET(X_51,5+1);

X_53:=FILTER(X_52,5);

X_54:=BACKSET(ISLASTBAR,BARSLAST(X_53)+1);

X_55:=X_54>REF(X_54,1);

X_56:=REF(LOW,5)=LLV(LOW,2*5+1);

X_57:=FILTER(X_56,5);

X_58:=BACKSET(X_57,5+1);

X_59:=FILTER(X_58,5);

X_60:=BACKSET(ISLASTBAR,BARSLAST(X_59)+1);

X_61:=X_60>REF(X_60,1);

X_62:=10;

X_63:=10;

X_64:=REF(HIGH,X_62)=HHV(HIGH,2*X_62+1);

X_65:=BACKSET(X_64,X_62+1);

X_66:=FILTER(X_65,X_62) AND HIGH=HHV(HIGH,X_62+1);

X_67:=BARSLAST(X_66);

X_68:=IF(X_66,CURRBARSCOUNT,0);

X_69:=IF(X_67,REF(X_68,X_67),X_68);

X_70:=CONST(X_69);

X_71:=REF(X_69,X_67+1);

X_72:=CONST(X_71);

X_73:=REF(LOW,X_63)=LLV(LOW,2*X_63+1);

X_74:=BACKSET(X_73,X_63+1);

X_75:=FILTER(X_74,X_63) AND LOW=LLV(LOW,X_63+1);

X_76:=BARSLAST(X_75);

X_77:=IF(X_75,CURRBARSCOUNT,0);

X_78:=IF(X_76,REF(X_77,X_76),X_77);

X_79:=CONST(X_78);

X_80:=REF(X_78,X_76+1);

X_81:=CONST(X_80);

X_82:=BACKSET(ISLASTBAR,SUMBARS(VOL,CAPITAL));

X_83:=X_82>REF(X_82,1);

NOTEXT1上:DRAWLINE(CURRBARSCOUNT=X_40,HIGH,CURRBARSCOUNT=X_38,HIGH,1),COLORGRAY;

NOTEXT1下:DRAWLINE(CURRBARSCOUNT=X_49,LOW,CURRBARSCOUNT=X_47,LOW,1),COLORGRAY;

NOTEXT1:IF(X_29,X_25,DRAWNULL),POINTDOT,COLORLIGRAY;

NOTEXT2:IF(X_27,X_19,DRAWNULL),POINTDOT,COLORLIGRAY;

NOTEXT3:IF(X_30,X_26,DRAWNULL),POINTDOT,COLORLIGRAY;

NOTEXT4:IF(X_28,X_20,DRAWNULL),POINTDOT,COLORLIGRAY;

高压:DRAWLINE(CURRBARSCOUNT=X_72,HIGH,CURRBARSCOUNT=X_70,HIGH,1),COLORMAGENTA;

低撑:DRAWLINE(CURRBARSCOUNT=X_81,LOW,CURRBARSCOUNT=X_79,LOW,1),COLORMAGENTA;

短压:DRAWLINE(X_53,HIGH,X_55,HIGH,1),COLORYELLOW;

短撑:DRAWLINE(X_59,LOW,X_61,LOW,1),COLORYELLOW;

X_84:=MA(MA(CLOSE,3),1);

轨道:MA(MA(CLOSE,3),3),COLOR32CD32,LINETHICK2;

NOTEXT_升:IF(X_84>=轨道,轨道,DRAWNULL),COLORMAGENTA,LINETHICK2;

涨家数:INDEXADV,NODRAW,COLORRED;

跌家数:INDEXDEC,NODRAW,COLORCYAN;

流通市值:FINANCE(40)/100000000,NODRAW,COLORRED;

流通亿股:FINANCE(7)/100000000,NODRAW,COLOR0080FF;

日成交亿:AMOUNT/100000000,NODRAW,COLORMAGENTA;

净买额:(DYNAINFO(23)-DYNAINFO(22))*CLOSE/1000000,NODRAW,COLORRED;

买卖比:DYNAINFO(23)/DYNAINFO(22),NODRAW,COLORWHITE;

X_85:=IF(PERIOD=16,0.03,IF(PERIOD=15,0.03,IF(PERIOD=14,0.006,IF(PERIOD=11,0.02,IF(PERIOD=10,0.02,IF(PERIOD=9,0.02,IF(PERIOD=8,0.002,IF(PERIOD=7,0.05,IF(PERIOD=6,0.03,IF(PERIOD=5,0.018,IF(PERIOD=4,0.005,IF(PERIOD=3,0.004,IF(PERIOD=2,0.003,IF(PERIOD=1,0.0015,IF(PERIOD=0,0.0012,0)))))))))))))));

X_86:=MA(CLOSE,5);

X_87:=MA(CLOSE,10);

X_88:=REF(HIGH,5)=HHV(HIGH,11);

X_89:=REF(LOW,5)=LLV(LOW,11);

X_90:=BACKSET(X_88,6)>BACKSET(X_88,5);

X_91:=BACKSET(X_89,6)>BACKSET(X_89,5);

X_92:=IF(BARSLAST(X_90)=BARSLAST(X_91) AND X_86>X_87,X_90,IF(BARSLAST(X_91)>BARSLAST(X_90),X_90,0));

X_93:=IF(BARSLAST(X_90)=BARSLAST(X_91) AND X_87>X_86,X_91,IF(BARSLAST(X_90)>BARSLAST(X_91),X_91,0));

X_94:=X_92 AND HIGH=HHV(HIGH,BARSLAST(X_93));

X_95:=X_93 AND LOW=LLV(LOW,BARSLAST(X_92));

X_96:=IF(X_94,HIGH,DRAWNULL);

X_97:=IF(X_95,LOW,DRAWNULL);

X_98:=LOW>REF(HIGH,1) AND DAY!=REF(DAY,1);

X_99:=HIGH<REF(LOW,1) AND DAY!=REF(DAY,1);

X_100:=REF(LOW,BARSLAST(X_98));

X_101:=REF(HIGH,BARSLAST(X_99));

X_102:=REF(HIGH,BARSLAST(X_94));

X_103:=REF(LOW,BARSLAST(X_94));

X_104:=REF(HIGH,BARSLAST(X_94)+1);

X_105:=REF(LOW,BARSLAST(X_94)+1);

X_106:=REF(HIGH,BARSLAST(X_94)+2);

X_107:=REF(LOW,BARSLAST(X_94)+2);

X_108:=REF(HIGH,BARSLAST(X_95));

X_109:=REF(LOW,BARSLAST(X_95));

X_110:=REF(HIGH,BARSLAST(X_95)+1);

X_111:=REF(LOW,BARSLAST(X_95)+1);

X_112:=REF(HIGH,BARSLAST(X_95)+2);

X_113:=REF(LOW,BARSLAST(X_95)+2);

X_114:=IF(X_103<=X_105,X_106,X_104);

X_115:=IF(X_104<X_103,X_103,IF(X_103<=X_105,X_107,X_105));

X_116:=IF(X_111>X_108,X_108,IF(X_108>=X_110,X_112,X_110));

X_117:=IF(X_108>=X_110,X_113,X_111);

X_118:=X_102>X_116 AND X_94;

X_119:=X_109<X_115 AND X_95;

X_120:=X_118 AND X_102>X_108 AND X_103>X_109 AND X_105>X_109;

X_121:=X_119 AND X_109<X_103 AND X_108<X_102 AND X_110<X_102;

X_122:=HIGH<=REF(HIGH,1) AND LOW>=REF(LOW,1) OR (HIGH>=REF(HIGH,1) AND LOW<=REF(LOW,1));

X_123:=COUNT(X_122,BARSLAST(X_95));

X_124:=COUNT(X_122,BARSLAST(X_94));

X_125:=COUNT(X_98,BARSLAST(X_95));

X_126:=COUNT(X_99,BARSLAST(X_94));

X_127:=IF(X_123>0,X_123+2+笔,IF(X_124,X_124+2+笔,3));

X_128:=IF(X_125,X_127-X_125,IF(X_126,X_127-X_126,X_127));

X_129:=X_120 AND BARSLAST(X_121)>X_128;

X_130:=X_121 AND BARSLAST(X_120)>X_128;

X_131:=X_94 AND REF(HIGH,BARSLAST(X_94))>=REF(HIGH,BARSLAST(X_129)) AND BARSLAST(X_130)>BARSLAST(X_129) OR (X_118 AND COUNT(X_98,BARSLAST(X_119))>0 AND REF(HIGH,BARSLAST(X_118))>REF(HIGH,BARSLAST(X_129)));

X_132:=X_95 AND REF(LOW,BARSLAST(X_95))<=REF(LOW,BARSLAST(X_130)) AND BARSLAST(X_129)>BARSLAST(X_130) OR (X_119 AND COUNT(X_99,BARSLAST(X_118))>0 AND REF(LOW,BARSLAST(X_119))<REF(HIGH,BARSLAST(X_130)));

X_133:=IF(BARSLAST(X_132)>BARSLAST(X_131),REF(HIGH,BARSLAST(X_131)),REF(HIGH,BARSLAST(X_132)));

X_134:=IF(BARSLAST(X_131)>BARSLAST(X_132),REF(LOW,BARSLAST(X_132)),REF(LOW,BARSLAST(X_131)));

X_135:=X_131 AND HIGH=HHV(X_133,BARSLAST(X_132)+1) AND HIGH>REF(HIGH,1) AND BARSLAST(X_132)>BARSLAST(X_131);

X_136:=X_53 AND LOW=LLV(X_134,BARSLAST(X_131)+1) AND LOW<REF(LOW,1) AND BARSLAST(X_131)>BARSLAST(X_132);

X_137:=X_135 OR (X_94 AND REF(HIGH,BARSLAST(X_94))>REF(HIGH,BARSLAST(X_135)) AND BARSLAST(X_136)>BARSLAST(X_135));

X_138:=X_136 OR (X_95 AND REF(LOW,BARSLAST(X_95))<REF(LOW,BARSLAST(X_136)) AND BARSLAST(X_135)>BARSLAST(X_136));

NOTEXT高点:IF(X_129,HIGH,DRAWNULL),POINTDOT,COLORGREEN,LINETHICK4;

NOTEXT低点:IF(X_130,LOW,DRAWNULL),POINTDOT,COLORYELLOW,LINETHICK4;

NOTEXT上:DRAWLINE(X_130,LOW,X_129,HIGH,0),COLORGRAY;

NOTEXT下:DRAWLINE(X_129,HIGH,X_130,LOW,0),COLOR888888;

X_139:=BARSLAST(X_129);

X_140:=BARSLAST(X_130);

DRAWNUMBER(X_130,LOW,X_139),COLORYELLOW;

DRAWNUMBER(X_129,HIGH+HIGH*X_85,X_140),COLORGREEN;

DRAWNUMBER(ISLASTBAR,IF(BARSLAST(X_129)>BARSLAST(X_130),LOW,HIGH+HIGH*X_85),MIN(X_139,X_140)),COLORMAGENTA;

{牛熊通吃}

AA1:=AMOUNT/V;

BB1:=L<AA1*0.9;

CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;

DD1:=L<MA(C,5)*0.921;

EE1:=V<MA(V,5)*1.5;

FF1:=BB1 AND CC1 AND DD1 AND EE1;

DRAWTEXT(FF1,LOW*0.99,'老鼠仓'),COLOR4080FF;

{预测明天}

XXS:=MA(LOW,5)*(1-5/100);

XXS1:=MA(HIGH,5)*(1+5/100);

均线:=C,COLORGREEN;

AAAA:=CLOSE/REF(CLOSE,3)<=0.85 AND CROSS(C,XXS) AND C>REF(C,1),LINETHICK0 ;

DRAWTEXT(AAAA,L*0.95,'下影买'),COLORRED;

BBAA:=CROSS(XXS1,C);

DRAWTEXT(CROSS(XXS1,C),H,'开盘逃'),COLORWHITE;

DDDD:=CROSS(C,XXS1);

DRAWTEXT(DDDD,H,'明日走'),COLORYELLOW;

{兄弟指标}

AAA:=MA(LOW,5)*(1-5/100);

BBB:=(HHV(AAA,5)+LLV(AAA,5))/2;

DRAWTEXT(CROSS(BBB,L) AND BBB>REF(BBB,1),L*0.98,'←兄弟回马枪'),COLORWHITE;

{天河指标}

DIFL:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEAL:=EMA(DIFL,9);

DRAWTEXT(REF(CROSS(DEAL,DIFL),1) AND CROSS(DIFL,DEAL),L*0.97,'←天河回马抢'),COLORMAGENTA;

{见好就收}

VSR2:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;

VSR3:=SMA(VSR2,4,1);

VSR4:=SMA(VSR3,2,1);

DRAWTEXT(VSR4>82 AND VSR3>89,HHV(C,30)*1.02,'收'),COLORGREEN;

三连阴:=LAST(C<O,3,0);

三缩量:=LAST(VOL<REF(VOL,1),3,0);

选股1:=REF(三连阴,1)>0 AND REF(三缩量,1)>0 AND O<C;

DRAWTEXT(选股1,L*0.98,'▲一三买入法'),COLORRED;

H01:='【解禁时间】: ';

H02:=EXTERNSTR(0,7000);

DRAWTEXT_FIX(ISLASTBAR,0,1,0,STRCAT(H01,H02)),COLORYELLOW;

H03:='【质押比例%】: ';

H04:=EXTERNSTR(0,7001);

DRAWTEXT_FIX(ISLASTBAR,0,0.9,0,STRCAT(H03,H04)),COLORYELLOW;

巨量平台:REF(H,BARSLAST(V=HHV(VOL,120))),COLORYELLOW,LINETHICK1;
后台-系统设置-扩展变量-手机广告位-内容正文底部
版权声明

本文仅代表作者观点,不代表本站立场。
本文系作者授权发表,未经许可,不得转载。
本文地址:/chaogujiqiao/2019-06-29/601.html

留言与评论(共有 0 条评论)
   
验证码:
后台-系统设置-扩展变量-手机广告位-评论底部广告位

配资服务网-为学习炒股提供股票配资服务的股民学校!

http://www.peizifuwu.com/

统计代码 | 京ICP1234567-2号

配资服务网-为学习炒股提供股票配资服务的股民学校

免责申明:本网站内容转载与网络,

如有侵权,请联系peizifuwu@qq.com,

投资有风险,入市需谨慎!